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Do it!

& Ensure that

students select only one
cell.

A Make sure students
click the top haif of the
button, not the down-
arrow in the bottom half.

Tell students that if they
select a cell outside the
layout area, then the
PivotTable layout, the
PivotTable Tools, and the
PivotTable Field List task
pane will not be available.

Excel 2007: Advanced

A-1: Creating a PivotTable

Here’s how

Here’s why

1 Open PivotTable

2 Save the workbook as
My PivotTable

3 Select any cell in the range
A5:D105

4. Activate the Insert tab

5 In the Tables group, click the
PivotTable button

Click OK

6 Edit the Sheetl tab name to read
PivotTable :

7 Update the workbook

(From the current unit folder.) The Raw Data
worksheet contains the sales details for several
products. You’ll use the data in this worksheet
10 create a PivotTable,

In the current unit folder.
You’ll createa PivotTable based on this range.

If you select a cell within the range of the source
data, you don’t have to specify the range later.

To open the Create PivotTable dialog box. It
prompts you to select the location of the data
you want to analyze. You can use an external
data source or an Excel worksheet. The default
is the range it determines automatically from the
selected cell.

In this dialog box, you also specify the location
of the PivotTable report. You can create the
PivotTable in a new or existing worksheet. The
default selection is New worksheet.

A new worksheet, Sheetl, is added to the
workbook. This worksheet displays the layout of
the PivotTable; the PivotTable Field List task
pane appears; and the PivotTable Tools |

Options and Design tabs appear on the Ribbon.

Double-click the name, type the new one, and
press Enter.




Explanation

-

Do it!
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Add fields

You can add fields to a PivotTable to specify the data you want to display. The fields of
the source data appear in the PivotTable Field List task pane.

To add fields, drag a relevant field from the top of the PivotTable Field List to one of
the four areas at the bottom of the task pane. You can add more than one field to an
area, and you don’t need to add all fields to the table. To display data and not just
headings, you need to place at least one field in the X Values area.

After the fields are in place, you can filter the information that appears in the table by
selecting options from the Filter columns, Filter rows, or Report Filter lists. For
example, you can show all data values, or restrict the PivotTable to summarizing only a
couple of values.

A-2: Adding fields to a PivotTable

Here’s how Here’s why

1 Verify that the PivotTable sheetis ~ You’ll add fields in the PivotTable layout.
active

Observe the PivotTable Field List 1t displays the column headings of the source
task pane data in the PivotTable worksheet.

2 Point to Region The pointer turns into a four-headed arrow.
: You'll use Region as a report filter.

Drag Region to Report Filter, as
shown

(In the task pane.) In the worksheet, Region
appears in cell A1 with a drop-down arrow.

3 Drag Quarter to Row Labels  Toadd Quarter as a row field in the PivotTable.

4 Drag Product to Column Labels  To add Product as a column field.

5 Drag Sales to = Values To add Sales as the Values item. The PivotTable
shows the sum of the quarterly sales for several *
products. You can change the view by changing
the selections in the Filter Column, Filter Rows,
and Region lists. o :
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6 In the worksheet, click ag shown

Clear Basil Leaf, Cassia, and
Cloves

Click OK

7 Click as shown

From the Region list, select
Central

Click OK

8 In the Filter Columns list, select
Clear Filter from "Product”

Display data for all of the
products for all regions

9 Update the workbook

Column Labels F{:
Anise Seeds as

138662
145445

To display a drop-down menu that includes a
Product list. '

To specify that the only products shown will be
Anise Seeds and Chives.

The worksheet now shows the sales figures for
only Anise Seeds and Chives.

- A B

Region {All} Q

To display the Region list.

To specify that the view will include the sales of
Anise Seeds and Chives in the Central region
only.

To close the list. The PivotTable displays the
sales of Anise Seeds and Chives in the Central
region.

To display data for all of the products.

In the Region list, select (AlL).
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Do it!

Ensure that students see
the line above Product,
not below it, before
releasing the mouse
button.

Excel 2007: Advanced

B-1:

Here’s how

Moving fields

Here’s why

1 Observe the PivotTable

2. In the PivotTable Field List task
pane, drag Product below
Quarter

3 Drag Quarter to Column Labels

4 Drag Region above Product, as
shown

5 Drag Region below Product

6 Observe the PivotTable

7 Update the workbook

It shows the quarterly sales of several products.
You’ll move the fields to show the datain a
different way.

The list of products appears beneath each
quarter name in the PivotTable.

(In the task pane.} Each quarter appears in a
column in the PivotTable.

You’ll change Region from a report filter to a
row label.

15 Rowlabels
i \\HR 'on Bl e
. Product e% i
RN «,,,;,}‘mh -
i |

To change Region from a report filter to a row
label, making the list of products appear
indented beneath each region name in the
PivotTable.

The order of the fields in the Row Labels list
affects the structure of the PivotTable.

The regions and products switch hierarchical
order in the spreadsheet, with regions now
appearing indented beneath products, as shown
in Exhibit 4-2.
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Do it! B-2: Hiding and showing details

Here’s how Here’s why

1 In the PivotTable Field List pane, under
Row Labels, drag Region above Product

Select A5:F34 ‘ You’ll hide the sales details for products and
show only the total sales for each region.

2 On the Ribbon, activate the If necessary.
PivotTable Tools | Options tab

3 In the Active Field group, click as Active Field: ez
shown Region ; =
-z
% Field Settings wk‘

Activs Field

To hide the product sales details.

Deselect the range

The order of the regions Sum of Sales |Column Labels »)

may differ for students. Row Labels v |atr1 Qtr2__ Q3 Qir4 _|Grand Total
#Central 123443 141203 139751 134895| 539298
#East 149506 151044 154530 160748] 615828
#North 168402 171468 169938 162776] 672584
#South 156152 161980 165738 166260] 650130
#wWest 183842 191342 200168 201285| 776637
Grand Total ___ 781345 817043 830125 825964] 3254477

The worksheet shows only a summary of the
sales details for each region.

4 Click as shown

To reveal the product details for the North
region. Next, you’ll show all of the details for all

Tegions.
5 Select AS:F14
6 On the Options tab, in the Active A cﬁ,;; Field: s
Field group, click as shown e *“3’5
Region E{

. AdweFied
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To show the regional sales details for each
product. '

7 Update the workbook




Explanation

=

Do it!

Point out that if there were
more than one North, Q1,
Anise Seeds entry, the
PivotTable cell value
would be the sum of the
rows’ values.

Have students click the
button’s icon, not the

down-arrow. You can also |

press Alt+F5.
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Refresh data

You cannot directly change the data in a PivotTable because it’s based on source data.

To change data in a PivotTable, you must first change the source data and then refresh
the PivotTable to reflect the latest changes. You can refresh the PivotTable by clicking
the Refresh button in the Data group on the Options tab.

B-3: Refreshing the data in a PivotTable

Here’s how Here’s why

1 Select B18 It shows the value 29269,

Enter 30000 Microsoft Excel

Cannot change this part of a PivotTable report.

When you try to enter the first character, a
message box appears with a warning that you
can’t change the value'in a PivotTable.

Click OK To close the message box.
2 Activate the Raw Data sheet This contains the source data for the PivotTable.

To change the data in the PivoiTable, you have
to change the values in the worksheet.

3 Select D46 The cell shows the value $29,269. You’ll change
this value and then view the result in the
PivotTable.
Edit D46 to read 30000 This cell is the only contributor to the value of .
, ~ B6.in the PivotTable.
4 Activate the PivotTable sheet ~ Notice that B18 still shows the old value.
5 Activate the Options tab A If necessary.

6 In the Data group, click the
Refresh button

Refresh

A4

(Click the icon in the top haif of t‘he,‘button’) To
update the PivotTable with the latest data. B18
now shows the new value. : '

7 Update the workbook
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- - Do it! C-1: Formatting by using a Pivot style
Here’s how Here’s why
1 Activate the Design tab | Under PivotTable Tools, on the Ribbon.

2 In the PivotTable Styles group,
click as shown

3. Under Medium, click as shown

To apply Pivot Style Medium 2 to the
PivotTable. The PivotTable appears as shown in
Exhibit 4-3.

4 Update the workbook




Do it!

C-2: Changing field settings

Here’s how
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Here’s why

1

Select B18

Activate the Options tab

In the Active Field group, click
Field Settings

Click Number Format

From the Category list, select
Number

Check
Use 1000 Separator (,)

From the Category list, select
Currency

Edit the Decimal places box to
read 0

Click OK

Click OK

Update the workbook

(If necessary.) This cell is in the data area.
You’ll:apply a number format to the data items.

To open the Value Field Settings dialog box,
shown in Exhibit 4-4. '

To open the Format Cells dialog box.

To display a comma after the thousands place in
the number.

To display the formatting options under
Currency. The $ option is selected in the Symbol
list. You’ll add this prefix symbol to the sales
values.

To specify that currency values should be
displayed as whole-dollar amounts,

To close the Format Cells dialog box,

To close the Value Field Settings dialog box and
apply the formatting to all Sales field values (not
just the selected cell). The values are now
formatted with commas and the $ symbol.




Do it!

Tell students that another
approach would be to
return to the Raw Data
sheet, click in the data,
display the PivotTable
menu (in the Tables group
on the Insert tab), and
choose PivotChart. This,
however, would generate
a new blank PivotTable
along with the PivotChart.

If necessary, tell students
to drag the PivotChart
Filter Pane to the right to
dock it next to the

PivotTable Field List pane.

If you have time, ask
students to experiment
with the PivotChart.

D-1:

Here’s how

Creating a PivotChart
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Here’s why

1 Click anywhere within the
PivotTable

2 - Activate the Options tab

In the Tools group, click
PivotChart

Click OK

3 In the PivotTable Field List pane,
drag Product to Report Filter

Observe the PivotChart

Resize and move the chart so it no
longer overlaps the table

4 From the Product list, select
Basil Leaf

Click OK
5 In the Column Labels list, clear all
of the options except Qtrl

Click OK

6 Update and close the workbook

(If necessary.) To indicate - which data touse for
the PivotChart.

If necessary.

To open the Insert Chart dialog box. You’ll
create the default Column chart.

To create a PivotChart in a:floating box on this
sheet. The PivotChart Filter Pane appears;
showing the active fields on the PivotChart. The
chart’s x-axis displays the Row Labels fields;
the tegend displays the Column labels fields;
and the bars represents the data values, You’ll
change the PivotTable and chart to show only
the total sales for each region.

To make Product a report filter. You can now
sort and filter data in the PivotChart by using
Product.

The total sales for the five regions appear in
columns, and each column is divided into quarters.
You can use the Product, Region, and Quarter
lists to change the data represented by the
PivotChart.

(If necessary.) Drag the chart box’s edges and
COIMErs as necessary.

The Product list is located in B1.

The PivotChart displays the total sales of only
Basil Leaf for all regions.

The chart displays the total sales of Basil Leaf in
the first quarter for all regions.




